System Requirements

To use the Private Area on your computer only a browser and an internet connection are needed.
The following browsers are supported:

Browser
Chrome 44 and later
Firefox 39 and later
Safari 8 and later
Internet Explorer 9 / 10 / 11
Concerning Internet Explorer, it is however recommended the use of Internet Explorer 11 as, beginning January 12, 2016, only the most current version of Internet Explorer (i.e. 11) will receive technical supports and security updates.

Minimum screen viewport required for mobile devices
667px (eg. iPhone 6, landscape view)